Website down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Apr 11, 2019 - 11:19 EEST
Investigating
The website is currently offline. Engineers have been paged and are working on resolving the issue.
Posted Apr 11, 2019 - 11:15 EEST
This incident affected: app.leadfeeder.com.