Billing down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Aug 31, 2019 - 16:57 EEST
Investigating
The billing service is currently offline. Engineers have been paged and are working on resolving the issue.
Posted Aug 31, 2019 - 16:52 EEST
This incident affected: buy.leadfeeder.com.