Integrations service down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Jul 03, 2020 - 02:21 EEST
Investigating
The integrations service is currently offline. Engineers have been paged and are working on resolving the issue.
Posted Jul 03, 2020 - 02:19 EEST
This incident affected: integrations.leadfeeder.com.