Degraded
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Jul 01, 2019 - 18:01 EEST
Investigating
We are experiencing degraded performance at the moment. Our team is working now to resolve this ASAP.
Posted Jul 01, 2019 - 17:29 EEST
This incident affected: app.leadfeeder.com.