Integrations service down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 14:46 EEST
Investigating
The integrations service is currently offline. Engineers have been paged and are working on resolving the issue.
Posted Jul 14, 2020 - 14:43 EEST
This incident affected: integrations.leadfeeder.com.