Degraded performance in Leadfeeder and delay showing new visits from companies

Incident Report for Leadfeeder

Resolved

Leadfeeder and the tracker are operating normally. The delay showing new Leads and Visits have been resolved.
Posted Sep 13, 2025 - 19:27 UTC

Monitoring

Leadfeeder is operating normally. New leads and visits are appearing normally in Leadfeeder's timeline. There are still some delays for Website traffic from the past 24 hours, which should recover during the next hours.
Posted Sep 13, 2025 - 14:00 UTC

Identified

We have identified the root cause and continue to work to remediate the issue
Posted Sep 13, 2025 - 06:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 12, 2025 - 20:53 UTC

Update

We are are still observing delays showing Leads and visits in Leadfeeder. We are working to remediate the situation
Posted Sep 12, 2025 - 19:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 11:19 UTC

Investigating

We are experiencing degraded performance in Leadfeeder, and a delay showing new visits from companies
Posted Sep 12, 2025 - 08:25 UTC
This incident affected: Leadfeeder and Tracker.