Integrations service down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted Mar 12, 2019 - 00:09 EET
Investigating
The integrations service is currently offline. Engineers have been paged and are working on resolving the issue.
Posted Mar 12, 2019 - 00:06 EET
This incident affected: integrations.leadfeeder.com.