Ongoing service disruption in the Echobot API

Incident Report for Leadfeeder

Resolved

This incident has been resolved
Posted Sep 11, 2025 - 14:13 UTC

Identified

We are currently experiencing availability issues affecting all the endpoints in the Echobot API. We are actively working to remediate the incident as soon as possible.
Posted Sep 11, 2025 - 11:56 UTC
This incident affected: Echobot API.