Problems loading leads
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2019 - 17:30 EEST
Investigating
We are sorry! The app is down at the moment, but we are working on it.
Posted 3 months ago. Jun 27, 2019 - 15:25 EEST
This incident affected: app.leadfeeder.com.