App down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 01, 2019 - 17:01 EEST
Investigating
The app is currently down. Engineers have been paged and are working on resolving the issue.
Posted 3 months ago. Jul 01, 2019 - 16:56 EEST
This incident affected: app.leadfeeder.com.