Website down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 17, 2019 - 13:59 EEST
Investigating
The website is currently offline. Engineers have been paged and are working on resolving the issue.
Posted 5 months ago. Apr 17, 2019 - 13:57 EEST
This incident affected: app.leadfeeder.com.