Integrations service down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 08, 2019 - 10:20 EET
Investigating
The integrations service is currently offline. Engineers have been paged and are working on resolving the issue.
Posted 6 months ago. Mar 08, 2019 - 10:16 EET
This incident affected: integrations.leadfeeder.com.