Website down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2019 - 15:56 EEST
Investigating
The website is currently offline. Engineers have been paged and are working on resolving the issue.
Posted 3 months ago. Jun 27, 2019 - 15:53 EEST
This incident affected: app.leadfeeder.com.