API down
Incident Report for Leadfeeder
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2019 - 17:20 EEST
Investigating
We are sorry! There's something broken and we are investigating it at the moment.
Posted 3 months ago. Jun 27, 2019 - 16:10 EEST
This incident affected: api.leadfeeder.com.